Control plane in azure::eastus is down

Incident Report for WarpStream Labs

Resolved

This incident has been resolved.
Posted Oct 30, 2025 - 00:36 UTC

Monitoring

The Azure eastus control plane has recovered. We are still closely monitoring updates from Azure: https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 23:44 UTC

Update

Seeing signs of recovery in the Azure eastus control plane. We expect full recovery within 3 hours according to the Azure status page: https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 20:34 UTC

Update

We are monitoring the Azure eastus control plane. It should recover within the next four hours according to Azure's status page: https://azure.status.microsoft/en-us/status.
Posted Oct 29, 2025 - 19:25 UTC

Update

We are suspecting that the issue is due to a cloud provider DNS outage. No other WarpStream regions are impacted.
Posted Oct 29, 2025 - 16:53 UTC

Investigating

We are investigating a connectivity issue with the Azure eastus control plane
Posted Oct 29, 2025 - 16:13 UTC
This incident affected: WarpStream Control Plane (Azure - eastus).