Control plane in aws::us-east-1 is down

Incident Report for WarpStream Labs

Resolved

The incident has been resolved.
Posted Oct 20, 2025 - 10:55 UTC

Update

The incident is resolving on the cloud provider's side. We are seeing all virtual clusters able to produce and fetch correctly. The control plane is fully operational from our point of view now. There are some customers whose agents have downscaled during the incident and who are reporting difficulties getting instances in us-east-1 to scale the agents back up.
Posted Oct 20, 2025 - 10:01 UTC

Monitoring

The cloud provider outage seems to be recovering. We are monitoring recovery, and are seeing signs that customers can produce and fetch correctly from their WarpStream clusters.
Posted Oct 20, 2025 - 09:47 UTC

Update

We are seeing early signs of recovery, which is aligned with the cloud provider status page update.
Posted Oct 20, 2025 - 09:38 UTC

Identified

The major outage is still ongoing on the cloud provider side, but they have identified a potential root cause.
Posted Oct 20, 2025 - 09:35 UTC

Update

We have confirmation the issue is due to an AWS outage in us-east-1. No other WarpStream regions are impacted.
Posted Oct 20, 2025 - 07:05 UTC

Investigating

One of our downstream dependency is down and therefore our control plane is unable to process any Kafka requests. Direct impact is that producing/consuming is not available.
Posted Oct 20, 2025 - 07:05 UTC
This incident affected: WarpStream Control Plane (AWS - us-east-1).